summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien LEFEBVRE2021-06-18 12:14:05 +0200
committerFabien LEFEBVRE2021-06-18 12:14:05 +0200
commit3af288fdace7ae86415d611a34795b571b6960e9 (patch)
treee696f5597ed7b4701c22475e49f467b9e3fa1e1a /PKGBUILD
parent62e08249dbe4a4c0344e343f63b4a7eef00265ac (diff)
downloadaur-3af288fdace7ae86415d611a34795b571b6960e9.tar.gz
upgpkg: mint 0.13.1-6
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2596050dc025..d1a6a2acb58f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,19 @@
pkgname=mint
pkgver=0.13.1
-pkgrel=5
+pkgrel=6
pkgdesc='A refreshing language for the front-end web'
arch=('x86_64')
url='https://github.com/mint-lang/mint'
license=('BSD')
-makedepends=('shards')
-source=("mint-${pkgver}::https://github.com/mint-lang/mint/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('35d1943d8deab5240471565ad90b0d26fe343baa69950ee87e03cfea61822f35')
-
-build() {
- cd "mint-${pkgver}"
-
- /usr/bin/shards build --progress --release
-}
+source=("https://github.com/mint-lang/mint/releases/download/${pkgver}/mint-${pkgver}-linux"
+ "https://raw.githubusercontent.com/mint-lang/mint/master/LICENSE")
+sha256sums=('f4264e018a1ee2be3bc9bc84e74e0f198f4258afe14aa1d7bd44edb930307c35'
+ '6b4ecb1a9202a35540d0405ddd88439bb4644a127afc02ee26428ca5d5c0bd9f')
+noextract=("mint-${pkgver}-linux"
+ "LICENSE")
package() {
- cd "mint-${pkgver}"
- install -Dm755 "bin/mint" "${pkgdir}/usr/bin/mint"
+ install -Dm755 "mint-${pkgver}-linux" "${pkgdir}/usr/bin/mint"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/mint/LICENSE"
}