summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien LEFEBVRE2021-06-18 10:34:31 +0200
committerFabien LEFEBVRE2021-06-18 10:34:31 +0200
commitdd1356f523b82e110a8f3e737099aad258f7e9f2 (patch)
tree8c9690ac494174c8b7952dc281d43dbe5c8c28fa /PKGBUILD
parentdba9af8cdb7cac733c875ebbf80d7175acf22111 (diff)
downloadaur-dd1356f523b82e110a8f3e737099aad258f7e9f2.tar.gz
upgpkg: mint 0.13.1-2
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c524f4721ac..d8f773ddf959 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
pkgname=mint
pkgver=0.13.1
-pkgrel=1
+pkgrel=2
pkgdesc='A refreshing language for the front-end web'
arch=('x86_64')
url='https://github.com/mint-lang/mint'
-source=("https://github.com/mint-lang/mint/releases/download/${pkgver}/mint-${pkgver}-linux"
- 'LICENSE')
-sha256sums=('f4264e018a1ee2be3bc9bc84e74e0f198f4258afe14aa1d7bd44edb930307c35'
- '6b4ecb1a9202a35540d0405ddd88439bb4644a127afc02ee26428ca5d5c0bd9f')
-noextract=("mint-${pkgver}-linux")
license=('BSD')
+makedepends=('shards')
+source=("mint-${pkgver}::https://github.com/mint-lang/mint/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('35d1943d8deab5240471565ad90b0d26fe343baa69950ee87e03cfea61822f35')
+
+build() {
+ cd "mint-${pkgver}"
+ PATH="/usr/bin" shards build --stats --progress --time --release --no-debug
+}
package() {
- install -Dm755 "mint-${pkgver}-linux" "${pkgdir}/usr/bin/mint"
+ cd "mint-${pkgver}"
+ install -Dm755 "bin/mint" "${pkgdir}/usr/bin/mint"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/mint/LICENSE"
}