summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Burgos2018-06-27 11:23:28 -0600
committerSam Burgos2018-06-27 11:23:28 -0600
commit025837897b0ecdb72714e249897682d72c83f6f1 (patch)
tree9029d3141f879300f26148a7745fa2c616c744f0 /PKGBUILD
downloadaur-025837897b0ecdb72714e249897682d72c83f6f1.tar.gz
created mintstick PKGBUILD with version 1.3.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dbfef8c4eda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Sam Burgos < sam dot burgos1089 at gmail dot com >
+
+pkgname=mintstick
+pkgver=1.3.8
+pkgrel=1
+pkgdesc="A GUI to write .img or .iso files to a USB Key. It can also format them"
+arch=('any')
+url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
+license=('GPL')
+depends=('coreutils'
+ 'dosfstools'
+ 'e2fsprogs'
+ 'exfat-utils'
+ 'glib2'
+ 'gtk3'
+ 'ntfs-3g'
+ 'parted'
+ 'polkit'
+ 'procps-ng'
+ 'python'
+ 'python2'
+ 'udisks2'
+ 'util-linux'
+ 'xapps')
+makedepends=('gettext')
+conflicts=("mintstick-git")
+source=("${pkgname}-${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('4fffcaa6d8484b67e82148061140aa87f1386194c4e9f01bf2c30e4a20ccab04')
+
+prepare() {
+ cd ${pkgname}
+ ## https://wiki.archlinux.org/index.php/Arch_packaging_standards#Directories
+ sed -i 's| /usr| "'$pkgdir'"/usr|g' install.sh
+
+ ## Removing all instances of KDE4, since Linux Mint KDE Edition is no longer available
+ rm -rf 'share/kde4'
+}
+
+package() {
+ cd ${pkgname}
+
+ ## Creating the directories to copy the files
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/usr/share/polkit-1/actions"
+ cp -rp share/nemo "$pkgdir/usr/share"
+
+ ## install.sh script is the one who contains all the installation process
+ ./install.sh
+}