summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Eriksson2018-07-29 20:23:06 +0200
committerSimon Eriksson2018-07-29 20:23:06 +0200
commit3ce32175701fba3e5cfba7cc2850be503856ddcf (patch)
tree6d217c04704360e2dfc5b1852c48ddf4fc76088e /PKGBUILD
parenta50f0297c071fab17114e245ba13fa34891c097d (diff)
downloadaur-3ce32175701fba3e5cfba7cc2850be503856ddcf.tar.gz
Update to 2.31.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 292ab7036b1f..c76550abd147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_target=mips64-elf
pkgname=${_target}-binutils
-pkgver=2.29.1
+pkgver=2.31.1
pkgrel=1
pkgdesc="A set of programs to assemble and manipulate binary and object files (${_target})"
url="http://www.gnu.org/software/binutils/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
depends=('zlib')
source=("ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.xz")
-sha256sums=('e7010a46969f9d3e53b650a518663f98a5dde3c3ae21b7d71e5e6803bc36b577')
+sha256sums=('5d20086ecf5752cc7d9134246e9588fa201740d540f7eb84d795b1f7a93bca86')
prepare() {
cd binutils-${pkgver}
@@ -19,16 +19,7 @@ prepare() {
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
}
-check() {
- cd binutils-$pkgver
-
- # unset LDFLAGS as testsuite makes assumptions about which ones are active
- # do not abort on errors - manually check log files
- make LDFLAGS="" -k check
-}
-
build() {
-
cd binutils-${pkgver}
./configure \
@@ -39,7 +30,6 @@ build() {
--with-gnu-ld \
--enable-64-bit-bfd \
--enable-plugins \
- --enable-static \
--disable-gold \
--disable-multilib \
--disable-nls \
@@ -49,13 +39,21 @@ build() {
make
}
+check() {
+ cd binutils-${pkgver}
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
+ # do not abort on errors - manually check log files
+ make LDFLAGS="" -k check || true
+}
+
package() {
cd binutils-${pkgver}
make DESTDIR="$pkgdir" install
# Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
# Remove info documents that conflict with host version
rm -rf "$pkgdir"/usr/share/info