summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Semkin2018-09-22 16:17:19 +0300
committerIvan Semkin2018-09-22 16:17:19 +0300
commit4c60f35e34cbebd0147fcc72fe9b7a9019eebb52 (patch)
treebbebfe337c07d0513b3acde38c041f7d398290f6 /PKGBUILD
parent857235b6f9eefe5f26a064be062bd7aa4bbddeae (diff)
downloadaur-4c60f35e34cbebd0147fcc72fe9b7a9019eebb52.tar.gz
Bump to 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa1ce8bcff32..7dde114ec199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
# Contributor: kikadf <kikadf.01@gmail.com>
pkgname=mir
-pkgver=0.32.0
-pkgrel=3
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Canonical's display server"
url='https://mir-server.io'
arch=(x86_64 i686)
license=(GPL LGPL)
conflicts=(mir)
provides=(mir)
-depends=(boost gcovr lcov capnproto google-glog gflags libglvnd valgrind liburcu lttng-ust libepoxy nettle libinput libxml++2.6 libxkbcommon python-pillow freetype2 gmock libevdev umockdev python-dbusmock protobuf python-dbus python-gobject hicolor-icon-theme lib32-glibc)
-makedepends=(glm doxygen cmake)
+depends=(gtest boost-libs capnproto google-glog gflags libglvnd liburcu lttng-ust libepoxy libxml++2.6 nettle libinput libxkbcommon python-pillow freetype2 libevdev protobuf python-dbus python-gobject hicolor-icon-theme libxcursor yaml-cpp)
+makedepends=(git glm doxygen cmake boost gcovr gmock lcov valgrind python-dbusmock umockdev)
optdepends=('qterminal: required for miral demos'
'xcursor-dmz: required for miral demos'
'ttf-ubuntu-font-family: required for miral demos'
- 'qt5-wayland: required for miral demos')
+ 'qt5-wayland: required for miral demos'
+ 'qtubuntu: opt requirement for miral demos')
source=("https://github.com/MirServer/mir/releases/download/v${pkgver}/mir-${pkgver}.tar.xz"
'https://raw.githubusercontent.com/capnproto/capnproto/04fd66e2992a3ed38d686642a3c479a7f3e131c9/c%2B%2B/cmake/FindCapnProto.cmake')
-sha256sums=('7fc79361f00f11795ee6a8092af6008aa9b56f3c7693343a4b6fe5c167e332a9'
+sha256sums=('4fab613954e4afc3964b1b397fc1edf4fd0f7b9ad5e63391e6cf2c08194136a0'
'83153402ea0220a9ed3f9d2c2c157eb49fedf340f368cd8173f0966b3fbf2647')
BUILD_DIR=build