summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author5chdn2016-01-25 12:35:37 +0100
committer5chdn2016-01-25 12:35:37 +0100
commit8e19441aaca0185426c09b7f9a5ef43c260613f4 (patch)
tree8db25d3429458f5e3cbc35bd564f3c483017025f /PKGBUILD
parent497b0a3e5c6a08908d9472acdb6fcf0483899d1e (diff)
downloadaur-8e19441aaca0185426c09b7f9a5ef43c260613f4.tar.gz
Remove client from dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 24 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ca2033deec5..a4dc35892621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,32 @@
pkgname=mist
pkgver=0.3.8
_pkgver=0-3-8
-pkgrel=2
+pkgrel=3
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
arch=('x86_64')
-depends=('gmp'
- 'leveldb'
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quickcontrols'
- 'qt5-webengine'
- 'readline'
- 'geth')
-provides=('mist'
- 'libnode')
-conflicts=('mist-git'
- 'libnode'
- 'libnode-git')
-url="https://github.com/ethereum/$pkgname"
+depends=(
+ 'gmp'
+ 'leveldb'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quickcontrols'
+ 'qt5-webengine'
+ 'readline'
+)
+provides=(
+ 'mist'
+ 'libnode'
+)
+conflicts=(
+ 'mist-git'
+ 'libnode'
+ 'libnode-git'
+)
+optdepends=(
+ 'geth: The go-ethereum commandline client.'
+ 'ethereum: The cpp-ethereum commandline client.'
+)
+url="https://github.com/ethereum/mist"
license=('GPL')
source=("${pkgname}-${_pkgver}.zip::https://github.com/ethereum/$pkgname/releases/download/v${pkgver}/Ethereum-Wallet-linux64-$_pkgver.zip")
sha256sums=("6a96a2e18e21ce8b1995b508e05d7a59a701a5aa75a82624c4286a7f8ec9eee5")