summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFFY002018-07-18 15:59:28 +0100
committerFFY002018-07-18 15:59:28 +0100
commit494767eb4907d7cbc64a3c15145910cfbe33485f (patch)
treeb822dfe9749c988e2431fe0491c46a4798375d6c /PKGBUILD
parent7c99d5e2b8ad48073d9bf56cc135773737d254b3 (diff)
downloadaur-494767eb4907d7cbc64a3c15145910cfbe33485f.tar.gz
pkgbuild: change libdiir in cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af2b77d69ea4..fbcf555a0e4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: FFY00 <filipe.lains@gmail.com>
pkgname=mitmproxy-git
_pkgname=${pkgname%-git}
-pkgver=4.0.0.r90.9829fe150
+pkgver=5.0.0.dev.7f464b8
pkgrel=1
pkgdesc="An interactive TLS-capable intercepting HTTP proxy."
arch=('any')
@@ -14,7 +14,7 @@ depends=(
'python-ruamel-yaml' 'python-setuptools' 'python-sortedcontainers' 'python-tornado'
'python-urwid' 'python-wsproto' 'python-asynctest' 'python-parver'
)
-checkdepends=('python-beautifulsoup4' 'python-flask' 'python-pytest-runner')
+checkdepends=('python-beautifulsoup4' 'python-flask' 'python-pytest-runner' 'python-tox')
conflicts=('mitmproxy')
provides=('mitmproxy')
source=("git+https://github.com/mitmproxy/mitmproxy.git")
@@ -22,7 +22,9 @@ sha1sums=('SKIP')
pkgver() {
cd "$srcdir"/$_pkgname
- git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
+ #git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
+ python -c "from mitmproxy import version ; print(version.get_dev_version())" | \
+ sed -e 's| .*commit |.|g' -e 's|)||g'
}