summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFFY002018-04-26 22:33:40 +0100
committerFFY002018-04-26 22:33:40 +0100
commitb2e4630ba4af6d8500a39f479bc4b788f3979e18 (patch)
treece40a4226572b25ed57bbc5f09c1a15dda510dbb /PKGBUILD
parent573455357011ddd9cfde9230cc40ef571233a1cd (diff)
downloadaur-b2e4630ba4af6d8500a39f479bc4b788f3979e18.tar.gz
pkgbuild: change remote name
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 218e8ab8de70..cce49dfc61e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,15 @@ license=('MIT')
depends=('openssl' 'python2-urwid' 'python2-pyopenssl' 'python2-pyasn1' 'python2-imaging' 'python2-lxml' 'python2-flask' 'python2-requests' 'python2-passlib' 'python2-configargparse' 'python2-tornado' 'python2-blinker>=1.3' 'python2-pyperclip>=1.5.8')
conflicts=('mitmproxy')
provides=('mitmproxy')
-source=("remote::git+https://github.com/mitmproxy/mitmproxy.git")
+source=("${pkgname%git}remote::git+https://github.com/mitmproxy/mitmproxy.git")
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/remote"
+ cd "$srcdir/${pkgname%git}remote"
git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
}
package() {
- cd "$srcdir/remote"
- python2 setup.py install --root=${pkgdir} || return 1
+ cd "$srcdir/${pkgname%git}remote"
+ python2 setup.py install --root=$pkgdir || return 1
}