summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDany Nativel2015-06-10 16:53:16 +0200
committerDany Nativel2015-06-10 16:53:16 +0200
commite138b521bd6d7ff171d0437de33358ea2f9d8a95 (patch)
tree72a637d4b76ad59201de5041f2f90a48e4ff3099 /PKGBUILD
downloadaur-e138b521bd6d7ff171d0437de33358ea2f9d8a95.tar.gz
Initial import to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8b94f6996b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: alphazo <alphazo@gmail.com>
+
+_gitname="mitmproxy"
+pkgname=mitmproxy-git
+pkgver=v0.11.3.r96.ge0c5f86
+pkgrel=1
+pkgdesc="mitmproxy is an SSL-capable, intercepting HTTP proxy. It provides a console interface that allows traffic flows to be inspected and edited on the fly."
+arch=('any')
+url="https://github.com/mitmproxy/mitmproxy"
+license=('GPL')
+depends=('openssl' 'python2-urwid' 'python2-netlib>=0.11.2' 'python2-pyopenssl' 'python2-pyasn1' 'python2-imaging' 'python2-lxml' 'python2-flask' 'python2-requests' 'python2-passlib' 'python2-configargparse' 'python2-tornado' 'python2-blinker>=1.3' 'python2-pyperclip>=1.5.8')
+conflicts=('mitmproxy')
+source=("git://github.com/mitmproxy/mitmproxy.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$_gitname"
+ python2 setup.py install --root=${pkgdir} || return 1
+}