summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2020-04-23 23:07:35 +0200
committerPellegrino Prevete2020-04-23 23:07:35 +0200
commitb84aa6050f5f8f421b91226adf26579a9fa6c0e0 (patch)
tree139df56f3fe75e4cbfc989e4810e35101a9aaaea /PKGBUILD
downloadaur-b84aa6050f5f8f421b91226adf26579a9fa6c0e0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78efac06c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Mantainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+
+pkgname=mkbootfs
+pkgver="4.4.4_r2.0.1"
+pkgrel=1
+pkgdesc='A tool to build android boot images.'
+arch=('i686' 'x86_64')
+url='https://android.googlesource.com/platform/system/core'
+license=('GPL')
+depends=('repo')
+makedepends=()
+source=('git+https://android.googlesource.com/platform/system/core#tag=android-4.4.4_r2.0.1')
+sha256sums=('SKIP')
+
+build() {
+ cd core/libmincrypt
+ gcc -c *.c -I../include
+ ar rcs libmincrypt.a *.o
+ cd ../cpio/
+ gcc mkbootfs.c -o mkbootfs -I../include
+}
+
+package() {
+ install -Dm644 "../src/core/cpio/mkbootfs" -t "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim: ts=2 sw=2 et: