summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2024-02-03 15:11:08 +0800
committerUniversebenzene2024-02-03 15:11:08 +0800
commitce35e60a1a2906243e23efdb52ebce4afe51d7fa (patch)
tree1e67604ed180cb81f24fd2775a129c30d18420e1 /PKGBUILD
parent19008baa795f18507cd2057c17c1af9e4973d7a1 (diff)
downloadaur-ce35e60a1a2906243e23efdb52ebce4afe51d7fa.tar.gz
Fix building and depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04ee11784208..4440a3352b50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,19 +10,21 @@ license=('MIT')
arch=("any")
conflicts=("python-mkdocs-git-revision-date-localized-plugin")
replaces=("python-mkdocs-git-revision-date-localized-plugin")
-depends=("mkdocs" "python-gitpython" "python-babel>=2.7.0" "python-pytz")
-makedepends=("pyhon-build" "python-setuptools" "python-wheel" "python-package")
+depends=("mkdocs" "python-gitpython" "python-babel>=2.7.0" "python-pytz" "python-markupsafe")
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
b2sums=('c06fa5193cb965b5b4d9b4d7c78949c0d85533ab6d60a76352cea404e9d2cab87d81647824ea13265f3be196ed79f1aba347e03b833e796c25a4373316dcf21d')
build(){
- cd "$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ python -m build --wheel --no-isolation
}
package(){
- cd "$pkgname-$pkgver"
- install -D -m 644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
- install -D -m 644 "README.md" -t "$pkgdir/usr/share/doc/$pkgname"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ install -D -m 644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m 644 "README.md" -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}