summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2021-07-01 01:26:46 +0200
committerAlphaJack2021-07-01 01:26:46 +0200
commitcc870a6f63f3d160441f65c7f438cfb93880345e (patch)
treeb61bc62cc0a91ebcae9a5cb300e557f3e2ec35c6 /PKGBUILD
downloadaur-cc870a6f63f3d160441f65c7f438cfb93880345e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f799616f1744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
+pkgname="mkdocs-minify-plugin"
+pkgver=0.4.0
+pkgrel=3
+pkgdesc="A mkdocs plugin to minify the HTML of a page before it is written to disk"
+url="https://github.com/byrnereese/mkdocs-minify-plugin"
+license=("MIT")
+arch=("any")
+conflicts=("python-mkdocs-minify-plugin")
+replaces=("python-mkdocs-minify-plugin")
+depends=("mkdocs" "python-htmlmin>=0.1.4" "python-jsmin>=2.2.2")
+makedepends=("python-setuptools")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=("d2a55eedb98bfb8c6239153176ab1157833f6bed1465fb126953e46998493683")
+
+build(){
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}