summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Maerz2020-05-23 20:08:52 +0200
committerRobert Maerz2020-05-23 20:08:52 +0200
commit5f69cc17cbb8907808bcccdb27510c5606f41c79 (patch)
tree01521b56d179f36821abf62e904596bde2c1e1d1 /PKGBUILD
parent88d2d0c562e1a354b367309cb99089c459dbbdeb (diff)
downloadaur-mkinitcpio-bluetooth.tar.gz
Updated to include recent pull requests; Moving to a git-tag-tarball release model
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24fe4d47ad98..08794bfbd9ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,27 @@
# Contributor: Aline Freitas <aline AT alinefreitas DOT com DOT br>
pkgname=mkinitcpio-bluetooth
-pkgver=1.3
+pkgver=1.4
pkgrel=1
pkgdesc="This is an initcpio hook for bluetooth connectivity during boot / in initramfs."
url="https://github.com/irreleph4nt/mkinitcpio-bluetooth/"
-arch=('x86_64' 'i686')
+arch=(
+ 'x86_64'
+ 'i686'
+)
license=('GPLv2')
-depends=('bluez' 'bluez-utils' 'dbus')
+depends=(
+ 'bluez'
+ 'bluez-utils'
+ 'dbus'
+)
+replaces=('mkinitcpio-btinput')
makedepends=('git')
-source=("git+https://github.com/irreleph4nt/mkinitcpio-bluetooth.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=("https://github.com/irreleph4nt/mkinitcpio-bluetooth/archive/v${pkgver}.tar.gz")
+md5sums=('a794ec95f1d37a56c824b7adc729ad96')
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/${pkgname}-${pkgver}"
install -Dm644 bluetooth_install "${pkgdir}/usr/lib/initcpio/install/bluetooth"
install -Dm644 bluetooth_hook "${pkgdir}/usr/lib/initcpio/hooks/bluetooth"