summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 09:49:07 +0200
committerChristian Hesse2015-06-30 09:49:07 +0200
commit75a808d244f33b6120439cd99cc068141955b0d8 (patch)
treec5146f8a5900ffd1253539ec7399d305a4cacfc2 /PKGBUILD
downloadaur-75a808d244f33b6120439cd99cc068141955b0d8.tar.gz
initial import of mkinitcpio-chkeymap 0.1.0.r2.g8c1a568-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8d4a057774d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=mkinitcpio-chkeymap
+pkgver=0.1.0.r2.g8c1a568
+pkgrel=1
+pkgdesc='Set keymap and timezone for main system inside initrd'
+arch=('any')
+makedepends=('git')
+url='https://github.com/eworm-de/mkinitcpio-chkeymap'
+license=('GPL')
+install=mkinitcpio-chkeymap.install
+backup=('etc/X11/xorg.conf.d/00-keyboard.conf')
+source=('git://github.com/eworm-de/mkinitcpio-chkeymap.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd mkinitcpio-chkeymap/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd mkinitcpio-chkeymap/
+
+ install -D -m0644 hook/chkeymap ${pkgdir}/usr/lib/initcpio/hooks/chkeymap
+ install -D -m0644 install/chkeymap ${pkgdir}/usr/lib/initcpio/install/chkeymap
+
+ install -D -m0644 etc/vconsole.conf ${pkgdir}/etc/vconsole.conf
+ install -D -m0644 etc/00-keyboard.conf ${pkgdir}/etc/X11/xorg.conf.d/00-keyboard.conf
+}
+