summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2018-06-06 15:52:37 +0200
committerChristian Hesse2018-06-06 15:52:37 +0200
commitbf6dcade4c02a56ddcb334bc8953d1b0527eef36 (patch)
treead039711482fa183631575457bc8eb905b952300 /PKGBUILD
parent21a4c3f7776f1a50d79fa3f16da30c617987b22c (diff)
downloadaur-bf6dcade4c02a56ddcb334bc8953d1b0527eef36.tar.gz
commit mkinitcpio-chkeymap 0.2.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d31bc693cba3..bc12f069f9e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,24 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=mkinitcpio-chkeymap
-pkgver=0.1.0.r3.g5e3f039
-pkgrel=2
+pkgver=0.2.0
+pkgrel=1
pkgdesc='Set keymap and timezone for main system inside initrd'
arch=('any')
+depends=('terminus-font')
makedepends=('git')
url='https://github.com/eworm-de/mkinitcpio-chkeymap'
license=('GPL')
install=mkinitcpio-chkeymap.install
backup=('etc/vconsole.conf'
'etc/X11/xorg.conf.d/00-keyboard.conf')
-source=('git://github.com/eworm-de/mkinitcpio-chkeymap.git')
+validpgpkeys=('BD84DE71F493DF6814B0167254EDC91609BC9183')
+source=("git://github.com/eworm-de/mkinitcpio-chkeymap.git#tag=${pkgver}?signed")
sha256sums=('SKIP')
-pkgver() {
- cd mkinitcpio-chkeymap/
-
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
- else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
- fi
-}
-
package() {
cd mkinitcpio-chkeymap/
- install -D -m0644 hook/chkeymap ${pkgdir}/usr/lib/initcpio/hooks/chkeymap
- install -D -m0644 install/chkeymap ${pkgdir}/usr/lib/initcpio/install/chkeymap
-
- install -D -m0644 etc/vconsole.conf ${pkgdir}/etc/vconsole.conf
- install -D -m0644 etc/00-keyboard.conf ${pkgdir}/etc/X11/xorg.conf.d/00-keyboard.conf
+ make DESTDIR="${pkgdir}" install
}