summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiang Gao2017-12-26 22:12:45 -0500
committerXiang Gao2017-12-27 01:21:24 -0500
commit9626dfc0aea269c4f1c2891ba40d177485209078 (patch)
tree9fe1e67eb97ee3b312dfcfd99878480b7c8df206 /PKGBUILD
parente9cf253911664b2937af7b235cc762f628a19fd5 (diff)
downloadaur-9626dfc0aea269c4f1c2891ba40d177485209078.tar.gz
use golang to get cache-id
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c400a964914a..adbd2ed89295 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Xiang Gao <qasdfgtyuiop at gmail dot com>
+
pkgname=mkinitcpio-docker-hooks
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="mkinitcpio hooks that provides support for using docker image as root"
arch=(any)
@@ -8,14 +9,20 @@ url="https://github.com/zasdfgbnm/mkinitcpio-docker-hooks"
license=('GPL')
groups=('base')
depends=('mkinitcpio' 'jq')
-backup=(etc/docker-btrfs.sh)
-source=('install_docker-btrfs' 'hooks_docker-btrfs' 'etc_docker-btrfs.sh')
-md5sums=('0da33ef9ff132737a09173fdd45cddd6'
- 'e1d51dd467412b48361c648226e6b57e'
- 'a1243d4a874f69ef696f5c6ac58424cb')
+backup=(etc/docker-btrfs.json)
+source=('install_docker-btrfs' 'hooks_docker-btrfs' 'etc_docker-btrfs.json' 'get-docker-cache-id.go')
+md5sums=('5ce9a3498b0af7e9fbbe830893da83e3'
+ 'b44c59a25ef2ff74e60d20aaabe683fd'
+ '4df2fd7306aef1e3d94ffc6b05056728'
+ 'bcae1950b172498e34c1aa4cb55ecad0')
+
+build() {
+ go build get-docker-cache-id.go
+}
package() {
+ install -Dm755 get-docker-cache-id "${pkgdir}/usr/bin/get-docker-cache-id"
install -Dm644 install_docker-btrfs "${pkgdir}/usr/lib/initcpio/install/docker-btrfs"
install -Dm644 hooks_docker-btrfs "${pkgdir}/usr/lib/initcpio/hooks/docker-btrfs"
- install -Dm644 etc_docker-btrfs.sh "${pkgdir}/etc/docker-btrfs.sh"
+ install -Dm644 etc_docker-btrfs.json "${pkgdir}/etc/docker-btrfs.json"
}