summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiang Gao2017-12-26 15:36:04 -0500
committerXiang Gao2017-12-26 17:10:20 -0500
commite9cf253911664b2937af7b235cc762f628a19fd5 (patch)
treeab06911e5dfc21b2e9ef3d3efb811d5f3fcf7abe /PKGBUILD
downloadaur-e9cf253911664b2937af7b235cc762f628a19fd5.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c400a964914a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Xiang Gao <qasdfgtyuiop at gmail dot com>
+pkgname=mkinitcpio-docker-hooks
+pkgver=1.0
+pkgrel=1
+pkgdesc="mkinitcpio hooks that provides support for using docker image as root"
+arch=(any)
+url="https://github.com/zasdfgbnm/mkinitcpio-docker-hooks"
+license=('GPL')
+groups=('base')
+depends=('mkinitcpio' 'jq')
+backup=(etc/docker-btrfs.sh)
+source=('install_docker-btrfs' 'hooks_docker-btrfs' 'etc_docker-btrfs.sh')
+md5sums=('0da33ef9ff132737a09173fdd45cddd6'
+ 'e1d51dd467412b48361c648226e6b57e'
+ 'a1243d4a874f69ef696f5c6ac58424cb')
+
+package() {
+ install -Dm644 install_docker-btrfs "${pkgdir}/usr/lib/initcpio/install/docker-btrfs"
+ install -Dm644 hooks_docker-btrfs "${pkgdir}/usr/lib/initcpio/hooks/docker-btrfs"
+ install -Dm644 etc_docker-btrfs.sh "${pkgdir}/etc/docker-btrfs.sh"
+}