summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKian Kasad2020-07-30 04:29:22 -0700
committerKian Kasad2020-07-30 04:29:22 -0700
commitd89ed5a243161e4210aa544bff787c478ec42295 (patch)
tree7558232e187a21f766da7d6640aad060f2128e87 /PKGBUILD
downloadaur-d89ed5a243161e4210aa544bff787c478ec42295.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64c8c625b58c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kian Kasad <kian at kasad.com>
+pkgname=mkinitcpio-encrypt-bootsplash
+pkgver=1.0
+pkgrel=1
+pkgdesc="a mkinitcpio hook to pause bootsplash for LUKS password input"
+arch=(x86_64)
+url="https://github.com/archlinux/svntogit-packages/tree/packages/cryptsetup/trunk"
+license=('GPL')
+depends=(cryptsetup linux-bootsplash)
+source=(
+ 'encrypt-hook'
+ 'encrypt-hook.patch'
+ 'encrypt-install'
+)
+sha256sums=(
+ '416aa179ce3c6a7a5eee0861f1f0a4fafac91b69e84a2aae82b6e5a6140e31e2'
+ '658cdae681c25d6c0abdaf6b3913c091d58e730c8e0124a5e3c24efeb2adbdd9'
+ 'd325dc239ecc9a5324407b0782da6df2573e8491251836d6c4e65fa61339ce57'
+)
+
+prepare() {
+ cd "$srcdir"
+
+ mkdir $pkgname
+ cp encrypt-hook encrypt-install -t $pkgname
+
+ cd $pkgname
+ patch -Np1 -i ../encrypt-hook.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm 0644 encrypt-hook -T "$pkgdir"/usr/lib/initcpio/hooks/encrypt-bootsplash
+ install -Dm 0644 encrypt-install -T "$pkgdir"/usr/lib/initcpio/install/encrypt-bootsplash
+}