summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 09:50:22 +0200
committerChristian Hesse2015-06-30 09:50:22 +0200
commit3a86a0825d370dc03b0c1e59003da30bf95cd3c2 (patch)
tree6d2d1db2f311b3591413fea3f29297bc30d49755 /PKGBUILD
downloadaur-3a86a0825d370dc03b0c1e59003da30bf95cd3c2.tar.gz
initial import of mkinitcpio-git 0.14.0.r0.g5294b46-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58c84f3b092a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Dave Reisner <dreisner@archlinux.org> ([core] package)
+# Maintainer: Thomas Bächler <thomas@archlinux.org> ([core] package)
+
+pkgname=mkinitcpio-git
+pkgver=0.14.0.r0.g5294b46
+pkgrel=1
+pkgdesc='Modular initramfs image creation utility - git checkout'
+arch=('any')
+url='http://www.archlinux.org/'
+license=('GPL')
+depends=('awk' 'mkinitcpio-busybox' 'kmod' 'util-linux' 'libarchive' 'coreutils'
+ 'bash' 'findutils' 'grep' 'filesystem' 'gzip' 'systemd-tools')
+optdepends=('xz: Use lzma or xz compression for the initramfs image'
+ 'bzip2: Use bzip2 compression for the initramfs image'
+ 'lzop: Use lzo compression for the initramfs image'
+ 'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
+provides=('mkinitcpio')
+conflicts=('mkinitcpio')
+backup=('etc/mkinitcpio.conf')
+source=('git://projects.archlinux.org/mkinitcpio.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd mkinitcpio/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd mkinitcpio/
+
+ make DESTDIR="${pkgdir}" install
+}
+