aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUlrich Ölmann2022-12-18 16:17:24 +0100
committerUlrich Ölmann2022-12-18 18:30:47 +0100
commit79359734b9475abbbf18d34e36dc8f8d9c28fbb2 (patch)
tree974a8986365925321daa39966039078eeaaf47e3 /PKGBUILD
downloadaur-79359734b9475abbbf18d34e36dc8f8d9c28fbb2.tar.gz
add initial package and resulting .SRCINFO
The latter has been created via makepkg --printsrcinfo > .SRCINFO and needs to be recreated most of the times when PKGBUILD is adjusted. Signed-off-by: Ulrich Ölmann <ulrich.oelmann@web.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 16 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f07cbde97786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Ulrich Ölmann <ulrich.oelmann@web.de>
+pkgname='mkinitcpio-kpartx'
+pkgver=0.1
+pkgrel=1
+pkgdesc='mkinitcpio hook allowing for a GPT partitioned LUKS device not needing LVM'
+url='https://github.com/OnkelUlla/mkinitcpio-kpartx'
+arch=('any')
+depends=('mkinitcpio' 'multipath-tools')
+source=('kpartx_hook' 'kpartx_install')
+sha256sums=('55cbf0e17f16930b39a66218f245cbd94446b675fb4f316588281b48ff4e4908'
+ '534b699571e345a508b31570c95ebae164351ad0052aca001f067b0cbde6b9f4')
+
+package() {
+ install --owner=root --group=root --mode=0644 -D ${srcdir}/kpartx_hook ${pkgdir}/usr/lib/initcpio/hooks/kpartx
+ install --owner=root --group=root --mode=0644 -D ${srcdir}/kpartx_install ${pkgdir}/usr/lib/initcpio/install/kpartx
+}