summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Sovetkin2015-06-08 11:06:08 +0200
committerEugene Sovetkin2015-06-08 11:06:08 +0200
commit05c09af0c87fbcee537ba5c4400acedadf3171d7 (patch)
tree8af917aeb1e568d0e58d2df2017d83368ac2d0e1 /PKGBUILD
downloadaur-05c09af0c87fbcee537ba5c4400acedadf3171d7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c6a0f1cfe91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jenya Sovetkin <e.sovetkin@gmail.com>
+pkgname=mkinitcpio-openswap
+pkgver=0.0.0
+pkgrel=2
+pkgdesc="mkinitcpio hook to open swap at boot time"
+arch=(any)
+license=('unknown')
+url="https://aur.archlinux.org/packages/mkinitcpio-openswap/"
+depends=(mkinitcpio)
+backup=('etc/openswap.conf')
+install="usage.install"
+source=('openswap.hook'
+ 'openswap.install'
+ 'openswap.conf')
+md5sums=('a5b52e3c3b5dc592f41567b21ec2e9cf'
+ 'ae743e0fd95cc1c07705cf7c472416b1'
+ '8a72bf00f155512490884eb4911cc4f4')
+
+
+package() {
+ install -Dm 644 openswap.hook \
+ "${pkgdir}/usr/lib/initcpio/hooks/openswap"
+ install -Dm 644 openswap.install \
+ "${pkgdir}/usr/lib/initcpio/install/openswap"
+ install -Dm 644 openswap.conf \
+ "${pkgdir}/etc/openswap.conf"
+}