summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEugene Sovetkin2015-06-08 11:11:44 +0200
committerEugene Sovetkin2015-06-08 11:11:44 +0200
commitf82c9aa4ac2cb3cdabcbaa78b296d6ceacd71b8d (patch)
tree0428f6c23a71873379f7e2d14523a8cf142688b5 /PKGBUILD
downloadaur-f82c9aa4ac2cb3cdabcbaa78b296d6ceacd71b8d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77d1d6352ed9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jenya Sovetkin <e.sovetkin@gmail.com>
+pkgname=mkinitcpio-shredkeyfiles
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="mkinitcpio hook to shred keyfiles during the boot"
+arch=(any)
+license=('unknown')
+url="https://aur.archlinux.org/packages/mkinitcpio-shredkeyfiles/"
+depends=(mkinitcpio)
+install="usage.install"
+backup=('etc/encrypt2.conf')
+source=('encrypt2.hook'
+ 'encrypt2.install'
+ 'encrypt2.conf')
+md5sums=('ac1b3ad839f3461bd3bc967c58a804be'
+ '6c4f19ba9a331e5b40825f7857bb40cd'
+ '50030f303d861649cfdc9f2ce7d9bb75')
+
+package() {
+ install -Dm 644 encrypt2.hook \
+ "${pkgdir}/usr/lib/initcpio/hooks/encrypt2"
+ install -Dm 644 encrypt2.install \
+ "${pkgdir}/usr/lib/initcpio/install/encrypt2"
+ install -Dm 644 encrypt2.conf \
+ "${pkgdir}/etc/encrypt2.conf"
+}