summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoe Holden2020-10-27 00:00:15 +0100
committerJoe Holden2020-10-27 00:00:15 +0100
commit2b7e4bffb02390d4a795b3b3aeccb2847c88f306 (patch)
tree0b1172357758210100bfbc36d45cd48365db0910 /PKGBUILD
downloadaur-2b7e4bffb02390d4a795b3b3aeccb2847c88f306.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b70629bbe3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# stolen from https://aur.archlinux.org/packages/mkinitcpio-tor/
+pkgname=mkinitcpio-tor-http
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Arch Linux mkinitcpio hook for running tor on the initramfs and requesting decryption keys"
+arch=('any')
+license=('BSD')
+depends=('tor' 'mkinitcpio-netconf' 'jq')
+source=('torhttp_hook' 'torhttp_install' 'torrc' 'config.sh')
+
+package() {
+ install -Dm644 "$srcdir/torhttp_hook" "$pkgdir/usr/lib/initcpio/hooks/torhttp"
+ install -Dm644 "$srcdir/torhttp_install" "$pkgdir/usr/lib/initcpio/install/torhttp"
+ install -Dm644 "$srcdir/torrc" "$pkgdir/usr/share/$pkgname/torrc"
+ install -Dm644 "$srcdir/config.sh" "$pkgdir/usr/share/$pkgname/config.sh"
+}
+
+
+
+md5sums=('4c9e7d637403b2848906bf44ba32cbfd'
+ '381258176f933d21e0fd7249920d4763'
+ 'fa551b003e0c8f908a5c3d4aa9bfb706'
+ 'bf6e7349c35f873d59a5e2d198a804fb')