summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCorey Hinshaw2020-10-26 23:58:56 -0400
committerCorey Hinshaw2020-10-26 23:58:56 -0400
commitb13dddabf258f5475814b293f3011303b8c09ffb (patch)
tree813a071c16ec651f4f38201aa5fd26e704c9c4fc /PKGBUILD
parent461db652b9b924dc1a024a1fe6f0054564ddd7b0 (diff)
downloadaur-b13dddabf258f5475814b293f3011303b8c09ffb.tar.gz
Update to 1.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e30370b7c4ff..f53eb35e65c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=mkinitcpio-tpm2-encrypt
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
pkgdesc="mkinitcpio hook that decrypts a TPM2-sealed LUKS keyfile"
url="https://github.com/electrickite/mkinitcpio-tpm2-encrypt"
@@ -9,12 +9,16 @@ arch=(any)
license=('GPL3')
depends=('mkinitcpio' 'tpm2-tools>=4.0')
source=("https://github.com/electrickite/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('1d33a42744927f6aad8960b0cec888b6fc3e78d1e6f856c948e1d0e0c2615f24')
+sha256sums=('5157ecdba2d4b8c11f21b78c513f227cafccded69f6c71c92523fda5b49c351a')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
install -Dm644 install_tpm2 "${pkgdir}/usr/lib/initcpio/install/tpm2"
- install -Dm644 hook_tpm2 "${pkgdir}/usr/lib/initcpio/hooks/tpm2"
+ install -Dm644 install_sd_tpm2 "${pkgdir}/usr/lib/initcpio/install/sd-tpm2"
+ install -Dm644 tpm2-unseal.service "${pkgdir}/usr/lib/systemd/system/tpm2-unseal.service"
+ install -Dm644 tpm2-cleanup.service "${pkgdir}/usr/lib/systemd/system/tpm2-cleanup.service"
+ install -Dm755 hook_tpm2 "${pkgdir}/usr/lib/initcpio/hooks/tpm2"
+ install -Dm755 tpm2_encrypt_hook "${pkgdir}/usr/bin/tpm2_encrypt_hook"
install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
}