summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-07-31 16:26:11 +0200
committersl1pkn072015-07-31 16:26:11 +0200
commitbadf23f63475263b7d42527467a4f941e37a885b (patch)
treea08131fb0a0b1c7a3265a94daa344e152ff8ddaa /PKGBUILD
parent498d74214e7342066bd8546c411795f41799bc74 (diff)
downloadaur-badf23f63475263b7d42527467a4f941e37a885b.tar.gz
Update to 5.2.2. Switch to QT5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0545afb0bec4..d21a73b68b57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,36 @@
# $Id: PKGBUILD,v 1.12 2003/11/06 08:26:13 dorphell Exp $
# Maintainer: Funkin-Stoopid <>
# Contributor: Funkin-Stoopid <>
+
pkgname=mkv-extractor-qt
-pkgver=5.2.1
+pkgver=5.2.2
pkgrel=1
pkgdesc="GUI for extract files from .mkv"
arch=('any')
-url="http://hizo.fr/linux/mkv_extractor_gui"
+url='http://hizo.fr/linux/mkv_extractor_gui'
license=('GPL3')
-depends=('python-pyqt4' 'mkvtoolnix-cli')
+depends=('python-pyqt5'
+ 'mkvtoolnix-cli')
optdepends=('ffmpeg: for DTS conversion'
'mkclean: MKV optimisation'
'mkvalidator: MKV check'
'tesseract: subtitle conversion'
'ogmrip: subtitle conversion')
+makedepends=('qt5-tools')
conflicts=('mkv-extractor-gui')
replaces=('mkv-extractor-gui')
install="${pkgname}.install"
-source=("http://hizo.fr/linux/mkv_extractor_gui/MKV-Extractor-Qt_sources_${pkgver}.tar.gz"
- 'mkv-extractor-qt.desktop')
-sha1sums=('da22ccbd748752034455e3173284e67005632d5f'
- '8036a3af674b1d3050ebd65c3838a4a3519b6a09')
-noextract=("MKV-Extractor-Qt_sources_${pkgver}.tar.gz")
-
-prepare() {
- mkdir -p build
- cd build
- bsdtar -xf "../MKV-Extractor-Qt_sources_${pkgver}.tar.gz"
-}
+source=("mkv-extractor_${pkgver}.tar.gz::https://launchpad.net/~hizo/+archive/ubuntu/mkv-extractor-gui/+files/mkv-extractor-qt5_${pkgver}.orig.tar.gz")
+sha1sums=('6cf50119f9b49a2d8060b0652f5831b051da9788')
build() {
- cd build
+ cd mkv-extractor-qt5
./build.sh
+ lrelease-qt5 *.ts
}
package() {
-
- cd build
+ cd mkv-extractor-qt5
# Create binary mkv-extractor-qt
echo "#!/bin/bash" > mkv-extractor-qt
@@ -50,11 +44,11 @@ package() {
install -Dm644 MKVExtractorQt_fr_FR.qm "${pkgdir}/usr/share/${pkgname}/MKVExtractorQt_fr_FR.qm"
# Install the .desktop file
- install -Dm644 ../mkv-extractor-qt.desktop "${pkgdir}/usr/share/applications/mkv-extractor-qt.desktop"
+ install -Dm644 mkv-extractor-qt.desktop "${pkgdir}/usr/share/applications/mkv-extractor-qt.desktop"
# Install the icon file
install -Dm644 img/mkv-extractor-qt.png "${pkgdir}/usr/share/pixmaps/mkv-extractor-qt.png"
# Install binary file
install -Dm755 mkv-extractor-qt "${pkgdir}/usr/bin/mkv-extractor-qt"
-} \ No newline at end of file
+}