summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-02 08:37:48 +0200
committerCarsten Teibes2014-08-02 08:37:48 +0200
commit89e72022a571971e5b296b229c7c65ef8605cad8 (patch)
treea896ace3d22de8f0ece353a113bf52d8e8843381 /PKGBUILD
parent9863bbdd872ba07961b5008a6b589e9264e8d828 (diff)
downloadaur-89e72022a571971e5b296b229c7c65ef8605cad8.tar.gz
[fix] Add fluidsynth dependency, cleanup
Use new flag for global installation, thanks @Ancurio!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c084df3c2a4..031eb09720a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-_name=mkxp
-pkgname=$_name-git
-pkgver=r403.843a7bf
+pkgname=mkxp-git
+pkgver=r470.151a1f0
pkgrel=1
pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)"
arch=('i686' 'x86_64')
url="https://github.com/Ancurio/mkxp"
license=('GPL2')
depends=('ruby' 'physfs-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
- 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++')
+ 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth')
makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
conflicts=('mkxp')
provides=('mkxp')
-install=$_name.install
-source=($_name::"git+$url.git")
+optdepends=('fluidsynth-git: reduced memory footprint for midi playback')
+install=mkxp.install
+source=("git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd $_name
+ cd mkxp
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_name
+ cd mkxp
- cmake ./ -DMRIVERSION=2.1
+ cmake ./ -DMRIVERSION=2.1 -DWORKDIR_CURRENT=ON
make
}
package() {
- cd $_name
+ cd mkxp
# install architecture dependent executeable
- install -Dm755 $_name.bin.x* "$pkgdir"/usr/bin/$_name
+ install -Dm755 mkxp.bin.x* "$pkgdir"/usr/bin/mkxp
# install documentation
- install -Dm644 README.md "$pkgdir"/usr/share/doc/$_name/README.md
- install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/$_name
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/mkxp/README.md
+ install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/mkxp
}