summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoberto Hueso Gomez2019-10-03 01:52:45 +0200
committerRoberto Hueso Gomez2019-10-03 01:52:45 +0200
commit2eccd2b92a262b71beeb368f8688f267b62bdbe4 (patch)
tree5aa1e712c3d2f908726737f346241cdf4de5c757 /PKGBUILD
parentb6b76a1e92e3ef3b5dc84799df485579772334b6 (diff)
downloadaur-2eccd2b92a262b71beeb368f8688f267b62bdbe4.tar.gz
Update to 3.2.1-1 and update dependencies
Also avoids building tests to improve building time.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 484bf2d59203..77cf38a53918 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: jerry73204 <jerry73204@gmail.com>
+# Maintainer: Roberto Hueso < robertohueso96 at gmail dot com >
+# Former Maintainer: jerry73204 <jerry73204@gmail.com>
# Former Maintainer: Govind Gopakumar < govind.93 at gmail dot com>
# Former Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=mlpack
-pkgver=3.1.1
-pkgrel=2
+pkgver=3.2.1
+pkgrel=1
pkgdesc='a scalable c++ machine learning library'
arch=('x86_64')
url="http://www.mlpack.org"
@@ -17,14 +18,19 @@ depends=(
'python-numpy'
'python-pandas>=0.15.0'
)
+
+optdepends=(
+ 'openmp: parallel computation support'
+)
+
makedepends=(
- 'cmake>=2.8.5'
+ 'cmake>=3.3.2'
'txt2man'
'python-setuptools'
'python-pytest-runner'
)
source=("http://www.mlpack.org/files/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a9901ea93655790fa66d55b52eb7a901754b6fedcc25b3258fd52709d2135e63')
+sha256sums=('3fa25157a0a6e91fd5ba223ebd911e5d86c0664d969ea3f7768d823448562f36')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -32,6 +38,8 @@ build() {
cmake \
-D CMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
-D BUILD_PYTHON_BINDINGS=ON \
+ -D BUILD_TESTS=OFF \
+ -D USE_OPENMP=ON \
.
make
}