summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvert Vorster2023-05-21 10:14:03 +0200
committerEvert Vorster2023-05-21 10:14:03 +0200
commited9681653b144563d3502c4f05efe5ddf6922200 (patch)
treee9516fc3e11a7ee5a015e6150d95fb54d3b1cd54 /PKGBUILD
parent9541f1504e62366dc23e7abed75b1b7f110350d5 (diff)
downloadaur-ed9681653b144563d3502c4f05efe5ddf6922200.tar.gz
License correction, and better versioning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fd4d4e7eb0d..6bb366527d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@ _srcname='mlt'
pkgbase=$_gitname-git
pkgname=('mlt-git')
pkgdesc='Multimedia Framework'
-pkgver=r5946.1673114203.0b1d574c
+pkgver=7.16.0.r16.56b1f62f
pkgrel=1
arch=('i686' 'x86_64')
-url="https://github.com/mltframework/${_srcname}" license=('GPL2')
+url="https://github.com/mltframework/${_srcname}" license=('LGPL2.1')
depends=( 'libsamplerate'
'sox'
'ffmpeg'
@@ -43,13 +43,9 @@ source=( "${_gitname}::git+${url}.git"
)
sha512sums=( 'SKIP' 'SKIP'
)
-pkgver(){ cd "${srcdir}/${_gitname}"
- printf 'r%s.%s.%s\n' \
- "$( git rev-list --count 'HEAD' )" \
- "$( git log --max-count='1' --pretty='format:%ct' )" \
- "$( git rev-parse --short 'HEAD' )"
+pkgver() {
+ git -C $_gitname describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
-
prepare(){ cd "${srcdir}/${_gitname}"
echo "Initialize Submodules"
@@ -60,12 +56,6 @@ prepare(){ cd "${srcdir}/${_gitname}"
echo "Updating git submodules"
git -c protocol.file.allow=always submodule update
-
-## Thanks to darling-git packager showing me how to do submodules.
-## There are some examples on how to deal with recursion in there too.
-# Old way of doing the submodule
-# cd ${srcdir}/${_gitname}/src/modules/glaxnimate
-# git submodule update
}
build(){ rm -rf build