summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLawrence Deneiple2018-04-06 13:57:38 +0200
committerLawrence Deneiple2018-04-06 13:57:38 +0200
commitf0d17d1b136d698eee3ae3cff7d0db22bcf7aa45 (patch)
treef1c9496d05ea7432cdd56b5fb2b5415ca4e758f2 /PKGBUILD
downloadaur-f0d17d1b136d698eee3ae3cff7d0db22bcf7aa45.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..201a3ed76100
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Barazok <barazok.blackrocks@gmail.com>
+pkgname=mlv
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="La bibliothèque MLV est une bibliothèque multimedia simplifiée. Cette bibliothèque convient parfaitement aux étudiants qui débutent dans la programmation en C et qui souhaitent ajouter des effets graphiques et sonores dans leurs programmes."
+arch=('any')
+url="http://www-igm.univ-mlv.fr/~boussica/mlv/api/French/html/index.html"
+license=('GPL')
+groups=()
+depends=('gcc' 'libtool' 'make' 'autoconf' 'doxygen' 'sdl' 'sdl_gfx' 'sdl_mixer' 'sdl_ttf' 'glib2' 'libxml2')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(http://download.savannah.gnu.org/releases/mlv/mlv-2.0.2/mlv-2.0.2.tar.gz)
+noextract=()
+md5sums=('1b29b677ea0123f92e4a0486139b57b1')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}