summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas P2021-12-15 18:28:41 +0200
committerLeonidas P2021-12-15 18:28:41 +0200
commitc0859948cd7a271be14cfd84dd4920d4957a0cc8 (patch)
treeb31775c840cec6929a27ab6ac890847688123197 /PKGBUILD
parente60c3b1ce0894304e55bcd5d0259a632e981fb25 (diff)
downloadaur-c0859948cd7a271be14cfd84dd4920d4957a0cc8.tar.gz
Use new git tree
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03cb6fc82e71..8ce15455a556 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,31 @@
-# Maintainer: Leo Papadakos <jpegxguy@outlook.com>
+# Maintainer: Leonidas P. <jpegxguy at outlook dot com>
# Contributor: Vincent Bernardoff <vb AT luminar.eu.org>
pkgname=mmc-utils-git
-pkgver=aef913e
+pkgver=a1b233c
pkgrel=1
pkgdesc="Userspace tools for MMC/SD devices"
-arch=(arm armv6h armv7h aarch64 x86_64 i686)
-url="https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git"
+arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
+url="https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git"
license=('GPL')
-depends=()
-makedepends=('git' 'make')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-install=
-source=('git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git')
-noextract=()
+source=('git://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --always --dirty --tags | sed -e 's/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --always --dirty --tags | sed -e 's/-/./g'
}
build() {
- cd "${pkgname%-git}"
- make all
+ cd "$srcdir/${pkgname%-git}"
+ make all
}
package() {
- cd "${pkgname%-git}"
- make DESTDIR="$pkgdir/" prefix=/usr install
- install -D man/mmc.1 "$pkgdir/usr/share/man/man1/mmc.1"
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" prefix=/usr install
+ install -D man/mmc.1 "$pkgdir/usr/share/man/man1/mmc.1"
}