summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaansu2021-06-13 04:00:01 -0700
committerRaansu2021-06-13 04:00:01 -0700
commit9ed0ad7663edd2d4fa84214b3c5fb0dfc23b0300 (patch)
tree3f100ba464f8b1eb338929c8f2ef9698f188762d /PKGBUILD
downloadaur-9ed0ad7663edd2d4fa84214b3c5fb0dfc23b0300.tar.gz
Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..609c2467c2f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lance G. <gero3977 at gmail dot com>
+# Contributor: Antoni Boucher <bouanto at zoho dot com>
+
+pkgname='mobile-config-firefox-git'
+pkgver=2.1.0+1+g92e1a26
+pkgrel=1
+pkgdesc="Mobile and privacy friendly configuration for Firefox"
+url="https://gitlab.com/postmarketOS/mobile-config-firefox"
+license=('GPL')
+arch=('x86_64' 'i686' 'pentium4' 'arm' 'armv6h' 'armv7h' 'aarch64')
+depends=('firefox')
+source=("$pkgname::git+https://gitlab.com/postmarketOS/mobile-config-firefox"
+ "0001-Update-links-for-ArchLinux.patch")
+sha256sums=("SKIP"
+ "be6c30de864c812edc897c9d7bf4896f646fa73268d945646032eb1a9a8926f0")
+
+prepare() {
+ cd $pkgname
+ patch --forward --strip=1 --input="${srcdir}/0001-Update-links-for-ArchLinux.patch"
+}
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/-/+/g; s/^v//'
+}
+
+build() {
+ cd $pkgname
+ make DISTRO=ArchLinux
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR=$pkgdir install
+}