summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlarchunix2016-09-30 22:53:29 +0200
committerlarchunix2016-09-30 22:53:29 +0200
commit63ee459751754ac4311d7892e04142816336a454 (patch)
tree58316a5141264f59896d7bbed59b68180235443f /PKGBUILD
parent95c2394e3710dab1d4d008d812bdb39cc122c0ad (diff)
downloadaur-63ee459751754ac4311d7892e04142816336a454.tar.gz
Use systemd-{sysusers,tmpfiles} to create mock group and dirs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdaa09c5e744..a510ada815ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,12 @@ optdepends=('createrepo_c: for mockchain command'
'yum-utils: to create RPMs for Fedora <= 23 (including EL5, EL6 and EL7)')
install="$pkgname.install"
backup=("etc/$pkgname/site-defaults.cfg")
-source=("$url/archive/$pkgname-$pkgver.tar.gz")
-md5sums=('e4d5b7424fd9c14fbe3b150367357a86')
+source=("$url/archive/$pkgname-$pkgver.tar.gz"
+ "$pkgname.sysusers"
+ "$pkgname.tmpfiles")
+md5sums=('e4d5b7424fd9c14fbe3b150367357a86'
+ 'd277502b9a95484594f86231d073dae0'
+ '1052fa4db74b59b0c195f4756bd865e8')
prepare() {
mv "$pkgname-$pkgname-$pkgver" "$pkgname-$pkgver"
@@ -50,6 +54,9 @@ package() {
-i "$pkgdir/etc/security/console.apps/$pkgname"
ln -s /usr/bin/consolehelper "$pkgdir/usr/bin/$pkgname"
fi
+
+ install -Dm644 "$srcdir/$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 "$srcdir/$pkgname.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
}
# vim: set ft=sh ts=4 sw=4 noet: