summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:00:35 +0100
committerBartłomiej Piotrowski2018-01-06 22:00:35 +0100
commit4dee6496422d38e01cdac03c43726a3c7213b36c (patch)
treeb13d3eb3c63b1104c8deae68a022b41fcc5a949c /PKGBUILD
downloadaur-4dee6496422d38e01cdac03c43726a3c7213b36c.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6cb487e04dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+_version=2.4.7-04
+pkgname=mod_itk
+pkgver=${_version//-/.r}
+pkgrel=1
+pkgdesc='Apache module that allows you to run each of your vhost under a separate uid and gid'
+arch=(x86_64)
+url='http://mpm-itk.sesse.net/'
+license=(APACHE)
+depends=(apache)
+source=(http://mpm-itk.sesse.net/mpm-itk-$_version.tar.gz)
+sha256sums=('609f83e8995416c5491348e07139f26046a579db20cf8488ebf75d314668efcf')
+
+build() {
+ cd mpm-itk-$_version
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd mpm-itk-$_version
+ install -D -m755 .libs/mpm_itk.so "$pkgdir/usr/lib/httpd/modules/mpm_itk.so"
+}