summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNixuge2023-06-21 16:41:18 +0200
committerNixuge2023-06-21 16:41:18 +0200
commit4515c483184c22a2ba0dab8d6ca138211bd95a97 (patch)
tree3d81d126fe3e4e3586e3a7063c7f57dc7b057716 /PKGBUILD
parentfead5acbfcdb3e9815e0f67717a3caa207a34788 (diff)
downloadaur-4515c483184c22a2ba0dab8d6ca138211bd95a97.tar.gz
Fixed hardcoded folder name
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47dd9aba8b61..c955fb253dbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=modrinth-app-git
_gitname=theseus
-pkgver=r135.9ea548c
+pkgver=r147.3f46882
pkgrel=1
pkgdesc='Official Modrinth launcher. Open-source, built by the community, for the community.'
url=https://github.com/modrinth/theseus
@@ -34,9 +34,10 @@ build() {
}
package() {
- # Just copy everything from the deb bundle folder
- # Pretty convinient isn't it?
- # TODO: generate the "modrinth-app_0.0.1_amd64" automatically
- cp -r "${srcdir}/theseus/target/release/bundle/deb/modrinth-app_0.0.1_amd64/data/usr/" \
+ # Grab the folder name (has the version embeeded in it)
+ folder=$(find . -type d -name "modrinth-app*") 2>/dev/null
+
+ # Then just copy everything from the deb bundle folder
+ cp -r "${folder}/data/usr/" \
"${pkgdir}"
}