summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfusion8092016-01-19 05:06:31 +1000
committerfusion8092016-01-19 05:06:31 +1000
commitec490bc7aa5563efb458554a9ae2a781dc79e9f1 (patch)
tree71705ae30e475137d052bb565c4a5f51fa22a190 /PKGBUILD
downloadaur-ec490bc7aa5563efb458554a9ae2a781dc79e9f1.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94f128e6841c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+
+pkgname=moksha
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A fork of the E17 window manager"
+arch=('i686' 'x86_64')
+url="http://mokshadesktop.org"
+license=('BSD')
+depends=('desktop-file-utils' 'e_dbus' 'elementary')
+optdepends=('acpid: power events on laptop lid close'
+ 'bc: calculator in everything module'
+ 'bluez4: bluetooth module'
+ 'connman: network module'
+ 'doxygen: build documentation'
+ 'evas_generic_loaders: provide support for SVG icons'
+ 'gdb: create backtraces on crash'
+ 'geoclue2: geolocation module')
+provides=('notification-daemon')
+conflicts=("enlightenment")
+backup=('etc/enlightenment/sysactions.conf'
+ 'etc/xdg/menus/e-applications.menu')
+source=("https://github.com/JeffHoogland/moksha/archive/$pkgver.tar.gz")
+sha256sums=('f03601558902b9f9b286d85aa5da418dfa74acf3e3947992dcb131cc0e44994e')
+install=('moksha.install')
+
+build() {
+ cd $pkgname-$pkgver
+
+ export CFLAGS="$CFLAGS -fvisibility=hidden"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}