summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Maftei2016-06-07 14:16:58 +0300
committerDan Maftei2016-06-07 14:16:58 +0300
commit63e99ac52e4dbf2e0200e63f80a50cfb14cb2bab (patch)
tree0326c18a5f40fd9f63dcf664b290552702665035 /PKGBUILD
downloadaur-63e99ac52e4dbf2e0200e63f80a50cfb14cb2bab.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3480756dbfeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Dan Maftei <dan.maftei@gmail.com>
+pkgname='molden'
+pkgver=5.6
+pkgrel=1
+pkgdesc="A visualization program of molecular and electronic structure"
+arch=('i686' 'x86_64')
+url="http://www.cmbi.ru.nl/molden/"
+license=('custom')
+groups=()
+depends=('mesa' 'glu')
+makedepends=('gcc-fortran'
+ 'xproto'
+ 'libx11'
+ 'mesa'
+ 'glu'
+)
+optdepends=('openbabel: to create 2D images of the molecules in a .sdf file')
+provides=('molden')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(ftp://ftp.cmbi.ru.nl/pub/molgraph/molden/$pkgname$pkgver.tar.gz)
+noextract=()
+md5sums=('9267c6fc6eef897668d7d7c2785e5f53')
+
+build() {
+ cd "$pkgname$pkgver"
+
+ # Patch Makefile for surf utility to reflect the replacement of
+ # missing makedepend
+ sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' surf/Makefile
+ make
+}
+
+package() {
+ cd "$pkgname$pkgver"
+ install -t "$pkgdir/usr/bin/" -Dm755 molden gmolden
+ install -t "$pkgdir/usr/lib/$pkgname/" -Dm755 ambfor/ambfor ambfor/ambmd surf/surf
+ install -t "$pkgdir/usr/share/doc/$pkgname" -Dm755 doc/figures.ps.Z doc/manual.ps.Z doc/manual.txt.Z
+ install -t "$pkgdir/usr/share/licenses/$pkgname/" -Dm755 CopyRight COMMERCIAL_LICENSE REGISTER
+}
+