summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMorten Linderud2017-07-30 17:58:06 +0200
committerMorten Linderud2017-07-30 17:58:06 +0200
commitd6e5cfaac99922b79573e0d84022328a233ae13e (patch)
tree24943fcfafe40090dc2bec8b9ef13ab25bcfdd85 /PKGBUILD
downloadaur-d6e5cfaac99922b79573e0d84022328a233ae13e.tar.gz
Initial upload: molecule 2.0.0.rc12-1
Added molecule Signed-off-by: Morten Linderud <morten@linderud.pw>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97f4d16c9e6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Morten Linderud <morten@linderud.pw>
+pkgname="molecule"
+pkgver=2.0.0.rc12
+pkgrel=1
+pkgdesc='Molecule aids in the development and testing of Ansible roles.'
+url='https://github.com/metacloud/molecule/tree/2.0.0.rc12'
+arch=('any')
+license=('MIT')
+makedepends=('python' 'python-setuptools')
+depends=('ansible-lint' 'python-colorama' 'flake8'
+ 'python-jinja' 'python-marshmallow' 'python-gilt'
+ 'python-tabulate' 'python-pbr' 'python-pexpect'
+ 'python-yaml' 'python-sh' 'python-click' 'yamllint')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/metacloud/molecule/archive/${pkgver}.tar.gz")
+sha256sums=('f27894ac47e37cf54be159a45e84b6adfae4127ec77e9c46a9c4bfeb5fc8ee24')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+# vim:set ft=sh ts=2 sw=2 et: