summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorElijah Gregg2022-01-16 20:35:16 -0700
committerElijah Gregg2022-01-16 20:35:16 -0700
commit581062a3f1f4123ba03e5220ad34f436028f8ded (patch)
treea3915366475f536c429538af6614bdcb35905795 /PKGBUILD
parentf866e551997f745ea994ab109223d24bcafd3634 (diff)
downloadaur-581062a3f1f4123ba03e5220ad34f436028f8ded.tar.gz
Fix moltengamepad package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aab017cab079..292b7fe97736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,37 @@
+# Maintainer: Elijah Gregg <lovetocode999@tilde.team>
# Contributor: chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
pkgname="moltengamepad"
-pkgver=1.1.0
+pkgver=1.2.1
pkgrel=1
pkgdesc="Flexible Linux input device translator, geared for gamepads"
url="https://github.com/jgeumlek/MoltenGamepad"
arch=('x86_64')
-_commit="6fd48a49a9ddb0b509b10f6e79ff3da3a49e925d"
license=('MIT')
-source=("https://github.com/jgeumlek/MoltenGamepad/archive/${_commit}.zip")
-md5sums=('80bcf71ebb0d0ea757e3089ac9bfc231')
+source=("https://github.com/jgeumlek/MoltenGamepad/archive/refs/tags/v${pkgver}.zip"
+ "https://patch-diff.githubusercontent.com/raw/jgeumlek/MoltenGamepad/pull/99.patch")
+sha256sums=('6ba8708953fd1ba08dd480bf33bdce678720842fbfdd1b5215c65e1700a0d869'
+ '1f724c23aadec8d8d09172e1db63e32f530e5b8b902de393bf1fa733c39c5a17')
+makedepends=('go-md2man')
depends=('scraw' 'scrawpp')
install="moltengamepad.install"
+prepare() {
+ cd "MoltenGamepad-${pkgver}"
+ patch -p1 "source/core/uinput.h" "${srcdir}/99.patch"
+}
+
build() {
- cd "MoltenGamepad-${_commit}"
+ cd "MoltenGamepad-${pkgver}"
sed -i '3 s/^#//' Makefile
sed -i '5 s/^#//' Makefile
sed -i '11 s|/usr/local/bin/|/usr/bin/|' installation/systemuser/systemd.service
+ make eventlists
make || return 1
}
package() {
- cd "MoltenGamepad-${_commit}"
+ cd "MoltenGamepad-${pkgver}"
mkdir -p $pkgdir/usr/bin/
mkdir -p $pkgdir/usr/lib/systemd/system/
install -Dm755 moltengamepad $pkgdir/usr/bin/moltengamepad