summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefano Aguilera2022-11-22 11:42:29 -0300
committerStefano Aguilera2022-11-22 11:42:29 -0300
commit9736d399cef4b60714c988a2fd031099f7478e34 (patch)
tree5388313f874203ee168cd4b27390cfc217479f4c /PKGBUILD
parentc478623e910df0459c9df2fb32927159f3a50e72 (diff)
downloadaur-9736d399cef4b60714c988a2fd031099f7478e34.tar.gz
Added udev rules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd6011d27d3d..e3750f292147 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Stefano Aguilera <stefano.aguilera.95@live.cl>
pkgname=monctl
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Monitor Control for Gigabyte G27Q"
arch=('any')
url="https://github.com/Gothem/monctl"
license=('MIT')
-depends=(python-qtpy python-pyusb)
+depends=(qt5-python-bindings python-qtpy python-pyusb)
makedepends=(python-build python-installer python-wheel python-hatchling)
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('4dccb6c6b7915f2fddb3a9f28e4c3812f62f7ce43b47fa5e3e2baec4b4786337')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
+ "50-gigabyte-monitor.rules")
+sha256sums=('4dccb6c6b7915f2fddb3a9f28e4c3812f62f7ce43b47fa5e3e2baec4b4786337'
+ '98eb3014f2577a26582482980c857ae27a2f79adae4ef50abb8bf7476df2f368')
build() {
cd "$pkgname-$pkgver"
@@ -18,7 +20,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
- echo $pkgdir
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -27,4 +28,7 @@ package() {
install -Dm 644 resources/monctl.svg "$pkgdir/usr/share/pixmaps/monctl.svg"
install -Dm 755 resources/monctl "$pkgdir/usr/bin/monctl"
-} \ No newline at end of file
+
+ cd $srcdir
+ install -Dm 644 50-gigabyte-monitor.rules "$pkgdir/usr/lib/udev/rules.d/50-gigabyte-monitor.rules"
+}