summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Koller2019-02-07 22:25:22 +0100
committerSebastian Koller2019-02-07 22:26:22 +0100
commit84ec648cecd6a2b6e793054d52d35397148a5618 (patch)
treeb035bb0e196609e6e29083294f215b782d80ed6a /PKGBUILD
parent2676c0152ec0034c1b5dfe61fa51f61735da8016 (diff)
downloadaur-moneyguru.tar.gz
Update to v2.13.1 and fix image path in desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 684a8be01d72..f151a335f1a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Koller <seb.koller@gmail.com>
pkgname=moneyguru
-pkgver=2.12.0
-pkgrel=2
+pkgver=2.13.1
+pkgrel=1
pkgdesc="Personal finance management application"
arch=('x86_64')
url="http://www.hardcoded.net/${pkgname}/"
@@ -9,12 +9,15 @@ license=('GPL3')
depends=('python' 'python-pyqt5')
makedepends=()
options=(!buildflags)
-source=(https://download.hardcoded.net/${pkgname}-src-${pkgver}.tar.gz)
-sha1sums=('a74fe0c1ef4ca8d30b30a4d4e61d7e0527c8ba74')
+source=(https://download.hardcoded.net/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('1107d08cba2c07c2bbd864387fd0bf3664373081')
-package() {
- make -C ${srcdir} PREFIX="/usr" DESTDIR="$pkgdir" install
- ln -sf /usr/share/moneyguru/run.py ${pkgdir}/usr/bin/moneyguru
+build() {
+ make -C ${srcdir}/${pkgname}-${pkgver} PREFIX="/usr" DESTDIR="$pkgdir"
}
-
+package() {
+ # Fix application icon by fixing single quotation mark in sed command
+ sed -i -e '/ICON/s/'"'"'/"/g' ${srcdir}/${pkgname}-${pkgver}/support/install.sh
+ make -C ${srcdir}/${pkgname}-${pkgver} PREFIX="/usr" DESTDIR="$pkgdir" install
+}