summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Dünkelmann2022-06-08 21:55:56 +0200
committerMartin Dünkelmann2022-06-08 21:55:56 +0200
commit87790a0bb93934e325a5b893e288a6d6a92ebb39 (patch)
tree93004112dd0a6f015d50c10f5d35fdd92ac425f1 /PKGBUILD
parent7f2a4abf1c3f01e095a638c83185db6f9a333102 (diff)
downloadaur-87790a0bb93934e325a5b893e288a6d6a92ebb39.tar.gz
refactor PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0c6a63819b6..a08349352dc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=moneymanagerex-git
pkgver=1.5.14
-pkgrel=1
+pkgrel=2
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest tagged version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
@@ -32,14 +32,16 @@ prepare() {
}
build() {
+ WXGTK_PATH=/opt/wxgtk-dev
+
cd "${srcdir}"/moneymanagerex
# Disable all warnings when building, then configure CMake
export CXXFLAGS=-w
- cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config-gtk3 .
+ cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=${WXGTK_PATH}/bin/wx-config-gtk3 .
# Make sure the linker bakes the non-standard path for wxWidgets into the executable
- export LD_RUN_PATH=/opt/wxgtk-dev/lib
+ export LD_RUN_PATH=${WXGTK_PATH}/lib
cmake --build . --target package
}