summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Dünkelmann2020-09-07 23:28:24 +0200
committerMartin Dünkelmann2020-09-07 23:28:24 +0200
commita08f4469e03dc3bad819dbad4edcc1947315eae3 (patch)
treebebf4ed4b9161f6f5474e70e703057070dae3569 /PKGBUILD
parent29bd709feac73b8b82b056c6c24fab43c93c3b9a (diff)
downloadaur-a08f4469e03dc3bad819dbad4edcc1947315eae3.tar.gz
Always point to the latest tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e566b90455d2..fe061b5ead45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,9 +16,14 @@ optdepends=('cups: for printing support')
replaces=('mmex')
provides=('moneymanagerex')
conflicts=('moneymanagerex')
-source=(git+https://github.com/moneymanagerex/moneymanagerex.git#tag=v$pkgver)
+source=(git+https://github.com/moneymanagerex/moneymanagerex.git)
sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --abbrev=0 | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${pkgname%-git}"
mkdir -p build