summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Dünkelmann2022-07-15 00:13:57 +0200
committerMartin Dünkelmann2022-07-15 00:13:57 +0200
commitc9dc0c896f01031eb804c3cd74ddbd4d476a0113 (patch)
tree65dffdea32467fb71f499b621d5cfa1988d20227 /PKGBUILD
parent87790a0bb93934e325a5b893e288a6d6a92ebb39 (diff)
downloadaur-c9dc0c896f01031eb804c3cd74ddbd4d476a0113.tar.gz
switch to official wxWidgets 3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a08349352dc9..0499135442c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=moneymanagerex-git
-pkgver=1.5.14
-pkgrel=2
+pkgver=1.5.16
+pkgrel=1
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest tagged version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
license=('GPL')
-depends=('wxgtk3-dev-opt' 'webkit2gtk')
+depends=('wxwidgets-gtk3' 'webkit2gtk')
makedepends=('curl' 'cmake' 'fakeroot' 'file' 'gawk' 'gcc' 'gettext' 'git' 'jq' 'lsb-release' 'make' 'pkg-config' 'rapidjson')
optdepends=('cups: for printing support')
replaces=('mmex')
@@ -32,16 +32,13 @@ prepare() {
}
build() {
- WXGTK_PATH=/opt/wxgtk-dev
-
cd "${srcdir}"/moneymanagerex
# Disable all warnings when building, then configure CMake
export CXXFLAGS=-w
- cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=${WXGTK_PATH}/bin/wx-config-gtk3 .
-
- # Make sure the linker bakes the non-standard path for wxWidgets into the executable
- export LD_RUN_PATH=${WXGTK_PATH}/lib
+
+ cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config .
+
cmake --build . --target package
}