summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrendan MacDonell2015-11-27 18:20:05 -0800
committerBrendan MacDonell2015-11-27 18:28:03 -0800
commitd072b92b2630f99f5ec4848138bea9890ce1fb39 (patch)
tree930a525c21f80288006766af5ca3389043de4298 /PKGBUILD
parent1d0d8a25b201c1dc82dfa541c573e27915f4d071 (diff)
downloadaur-d072b92b2630f99f5ec4848138bea9890ce1fb39.tar.gz
Upgrade to 4.0.0
Requires a couple new patches: - jsonc-compile.patch uses the version of json-c from the AUR, instead of installing a vendored-version site-wide (!) - subobject-access.patch fixes missing nested objects and related crashes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 21 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c94d7552ea11..5a1d2ee95b85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,34 @@
# Maintainer: Brendan MacDonell <brendan@macdonell.net>
pkgname=mongo_fdw
-pkgver=3.0
+pkgver=4.0.0
pkgrel=1
pkgdesc="PostgreSQL foreign data wrapper for MongoDB"
arch=('i686' 'x86_64')
-url="https://github.com/citusdata/mongo_fdw"
+url="https://github.com/EnterpriseDB/mongo_fdw"
license=('LGPL3')
-depends=(postgresql)
+depends=('mongo-c-driver>=1.2' 'postgresql')
+makedepends=('json-c')
install=mongo_fdw.install
-source=("https://github.com/citusdata/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('c2b9267c21199852ddd1989d447fd413')
+_relname="REL-${pkgver//\./_}"
+source=("https://github.com/EnterpriseDB/${pkgname}/archive/${_relname}.tar.gz"
+ 'jsonc-compile.patch'
+ 'subobject-access.patch')
+md5sums=('9705f9d0c9affefa4184fb66051b7c90'
+ '5052ecc1a0f48a6c9ca6e4488817369b'
+ '68a315f57525226505933f9d4ea7bad5')
+
+prepare() {
+ cd "${pkgname}-${_relname}"
+ patch -p1 -i ../jsonc-compile.patch
+ patch -p1 -i ../subobject-access.patch
+}
build() {
- cd "${pkgname}-${pkgver}"
- make
+ cd "${pkgname}-${_relname}"
+ make -f Makefile.meta
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}/" install
+ cd "${pkgname}-${_relname}"
+ make DESTDIR="${pkgdir}" -f Makefile.meta install
}