summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames P. Harvey2019-02-24 06:01:35 -0500
committerJames P. Harvey2019-02-24 06:52:31 -0500
commitda8fe1243e9df16ca48783a16cc833f125385ef5 (patch)
tree2c89d6cd6bccd84162cc746752f99066fecf28d6 /PKGBUILD
parent206b0d5f4f03b0fc0ed55a7d9af003157e880440 (diff)
downloadaur-da8fe1243e9df16ca48783a16cc833f125385ef5.tar.gz
Make systemd wait as long as it takes for MongoDB to start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae4bbf3bd361..f98e1cfae73e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=mongodb
# #.<odd number>.# releases are unstable development/testing
pkgver=4.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64")
url="https://www.${pkgname}.com/"
@@ -39,7 +39,7 @@ _scons_args=(
--use-sasl-client
--ssl
--disable-warnings-as-errors
- # --use-system-asio # https://jira.mongodb.org/browse/SERVER-21839 marked as fixed, but still doesn't compile. Mongodb uses custom patches.
+ # --use-system-asio # https://jira.mongodb.org/browse/SERVER-21839 marked as fixed, but still doesn't compile. MongoDB uses custom patches.
# --use-system-icu # Doesn't compile
--use-system-tcmalloc # in gperftools
# --use-system-boost # Doesn't compile
@@ -64,6 +64,11 @@ prepare() {
# Remove sysconfig file, used by upstream's init.d script not used on Arch
sed -i '/EnvironmentFile=-\/etc\/sysconfig\/mongod/d' rpm/mongod.service
+
+ # Make systemd wait as long as it takes for MongoDB to start
+ # If MongoDB needs a long time to start, prevent systemd from restarting it every 90 seconds
+ # See: https://jira.mongodb.org/browse/SERVER-38086
+ sed -i 's/\[Service]/[Service]\nTimeoutStartSec=infinity/' rpm/mongod.service
}
build() {