summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2022-07-21 11:03:08 -0300
committerRafael Fontenelle2022-07-21 15:03:51 -0300
commit766a621d0a5fe003ba86c9c13cb7b4a241695c7e (patch)
tree245f7a5cb1a9cb302fcfeab1173b2c393e8c776c /PKGBUILD
parentc3926df6dd01b884260dc158d923bdaa25beb816 (diff)
downloadaur-766a621d0a5fe003ba86c9c13cb7b4a241695c7e.tar.gz
Update to 6.0.0
mongo shell is returning an empty package, so the mongosh-bin is now promoted to depends array.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 713a6db1ee7b..7a53b2897ade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
#Maintainer: Rafael Fontenelle <rafaelff at gnome dot org>
pkgname="mongodb-bin"
-pkgver="5.0.9"
-_basever="5.0"
+pkgver="6.0.0"
+_basever="6.0"
_basedist="focal"
pkgrel="1"
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64" "aarch64")
url="https://www.mongodb.com/"
license=("custom:SSPLv1" "Apache")
-depends=("curl")
-optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities."
- "mongosh-bin: An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.")
+depends=(mongosh-bin curl)
+optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.")
provides=("mongodb=$pkgver")
conflicts=("mongodb" "mongodb-shell-bin")
backup=("etc/mongodb.conf")
@@ -25,17 +24,14 @@ source=(
"mongodb.tmpfiles"
"LICENSE")
source_x86_64=(
- mongodb-org-shell_${pkgver}_x86_64.deb::"${_repo_url}/binary-amd64/mongodb-org-shell_${pkgver}_amd64.deb"
mongodb-org-server_${pkgver}_x86_64.deb::"${_repo_url}/binary-amd64/mongodb-org-server_${pkgver}_amd64.deb"
mongodb-org-mongos_${pkgver}_x86_64.deb::"${_repo_url}/binary-amd64/mongodb-org-mongos_${pkgver}_amd64.deb"
)
source_aarch64=(
- mongodb-org-shell_${pkgver}_aarch64.deb::"${_repo_url}/binary-arm64/mongodb-org-shell_${pkgver}_arm64.deb"
mongodb-org-server_${pkgver}_aarch64.deb::"${_repo_url}/binary-arm64/mongodb-org-server_${pkgver}_arm64.deb"
mongodb-org-mongos_${pkgver}_aarch64.deb::"${_repo_url}/binary-arm64/mongodb-org-mongos_${pkgver}_arm64.deb"
)
noextract=(
- mongodb-org-shell_${pkgver}_${CARCH}.deb
mongodb-org-server_${pkgver}_${CARCH}.deb
mongodb-org-mongos_${pkgver}_${CARCH}.deb
)
@@ -44,15 +40,12 @@ sha256sums=('f2a79c7fcd75253ab1cb888541a0c0678bf3bb78700c79996e24a678f1e42850'
'47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b'
'51ee1e1f71598aad919db79a195778e6cb6cfce48267565e88a401ebc64497ac'
'09d99ca61eb07873d5334077acba22c33e7f7d0a9fa08c92734e0ac8430d6e27')
-sha256sums_x86_64=('aa0ccaed9f5a5673630e168de7f2e46aad77d3397b51c8f2877ff92ab56069ab'
- '748b3018c14372bd704966692e6fc9e49a13c6a79a454d465a7657478420eef0'
- '52884643d44f4ac1164ec1180f1755db5fdb631c2da5e39c480e9b45d92cd425')
-sha256sums_aarch64=('bda3191dcc3dc3fc05796f28ecefa82de84a7e66a84c8f4ade2b09d80c04b63c'
- '533c6b363d8300e450a0a8d86162cca6934f9c05fb16f52774e9d6a77e23658d'
- 'bfbb5453462ea7ffd2d7447f9a8dab613055ae92e1cf5bca0a0ad34b8d368b50')
+sha256sums_x86_64=('009510f09a3f4f83c39d8b458379e3519ca81fd5d7ce5799fa78ff9270812b38'
+ '6964004ad8d2c0dfb2b0f8679d96e0fceaf16e0ce8e11853625de77fe31009a8')
+sha256sums_aarch64=('9c49a94b61d479075e850022160c4a2e79d8555f5a3cab54b5bfc6452f5ffb83'
+ '57f63d2be57e51ab67c9072678cb9bc4eaf8727feda9aa8b1716f4dd16a4941b')
prepare() {
mkdir -p output
- bsdtar -O -xf mongodb-org-shell_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #mongo extracted
bsdtar -O -xf mongodb-org-server_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #server extracted
bsdtar -O -xf mongodb-org-mongos_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #mongos extracted
}