summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2024-04-24 00:12:14 +0200
committerDaniel Peukert2024-04-24 00:12:14 +0200
commitb8cab07d3a212a7833dc0622b5ef7c4eb18c3121 (patch)
treed225aab4e169af2ce469aacd2d35d78654280007 /PKGBUILD
parent220d1f7e72127fc30fb525f3a12ecb7e25fb748e (diff)
downloadaur-mongodb-compass-isolated.tar.gz
Update mongodb-compass-beta to 1.42.6-beta.2 (closes #498)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c1d36b6464b..32932638a1aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,11 @@ pkgdesc='The official GUI for MongoDB - Isolated Edition'
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.mongodb.com/products/compass'
license=('SSPL-1.0')
-
-_electronpkg='electron28'
+if [[ "$_target" =~ -beta$ ]]; then
+ _electronpkg='electron29'
+else
+ _electronpkg='electron28'
+fi
depends=("$_electronpkg" 'krb5' 'libsecret' 'lsb-release' 'nodejs>=16.15.1')
makedepends=('git' 'npm>=8.19.4' 'python' 'unzip')
optdepends=('org.freedesktop.secrets')