summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2023-10-07 16:18:06 +0200
committerDaniel Peukert2023-10-07 16:18:06 +0200
commite6767c901c8df6514647104123a27412595b93f8 (patch)
treeaebc46b98688936f64586ea381dae8bfffa22c70 /PKGBUILD
parent3453bf0420adc97803dcac2fa83b50c122064e00 (diff)
downloadaur-e6767c901c8df6514647104123a27412595b93f8.tar.gz
Fix mongodb-compass build with some AUR helpers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb27ba92a096..81287494da47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,10 @@ _sourcedirectory="compass-$_pkgver"
prepare() {
cd "$srcdir/$_sourcedirectory/"
+ # Due to a bug in lerna, having a git repo in the parent directory is not supported (this is the case in some AUR helpers),
+ # we init a git repo in our source directory to make sure this doesn't happen
+ git init
+
# Disable husky command
sed -i '/husky install/d' 'package.json'