summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2024-02-24 19:24:54 +0100
committerDaniel Peukert2024-02-24 19:24:54 +0100
commit1d39c952c7b06534ac4bd24a18bc212982955522 (patch)
tree885c4a853e1a4615c60da4184717881d64cf3fe8 /PKGBUILD
parent16c83c92fe343e010f334b2c49eded7558a3d2c6 (diff)
downloadaur-1d39c952c7b06534ac4bd24a18bc212982955522.tar.gz
Add check() to mongodb-compass-bin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 000daf1c4b62..f146c777fb5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,10 @@ _betaprefix="$([[ "$_pkgname" =~ -beta$ ]] && printf 'beta/' || printf '')"
source=("$pkgname-$pkgver.rpm::https://downloads.mongodb.com/compass/$_betaprefix$_pkgname-$_pkgver.x86_64.rpm")
sha512sums=('b2457017aed18ff93c653c4ff0bcc62e61b5f3a34835ed68e7967c2a6e6c71609ece44c920d71c5e80ee4cfd9de38f9d2bac97859ec3efbb9b5ff11f6e731ad3')
+check() {
+ "$srcdir/usr/lib/$_pkgname/MongoDB Compass$_edition" --version | tee '/dev/stderr' | grep -q "^MongoDB Compass$_edition $pkgver$"
+}
+
package() {
cd "$srcdir/"