summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeert Hendrickx2020-05-13 14:31:59 +0200
committerGeert Hendrickx2020-05-13 14:31:59 +0200
commit689ef5185b7994e64fbbed6a6ffc4512baf337c1 (patch)
tree691e859519cabb7f75a4179334e6c943849e2bfa /PKGBUILD
downloadaur-689ef5185b7994e64fbbed6a6ffc4512baf337c1.tar.gz
reimport and update from python2-mtools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71246238fe84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: reno.esper@gmail.com
+# Maintainer: geert@hendrickx.be
+
+pkgname=mongodb-mtools
+_pkgname=mtools
+pkgver=1.6.3
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/rueckstiess/mtools"
+pkgdesc="A collection of scripts to set up MongoDB test environments and parse and visualize MongoDB log files"
+license=('Apache License')
+depends=('python' 'python-dateutil' 'python-setuptools')
+optdepends=('python-psutil' 'python-pymongo' 'python-matplotlib' 'python-numpy')
+makedepends=('python-setuptools')
+source=("https://github.com/rueckstiess/mtools/archive/v$pkgver.tar.gz")
+sha256sums=('0a4cb7f256457d8fc89c4726e593866f42895355694d9c9018f5f4c679adda54')
+
+package() {
+ cd $srcdir/$_pkgname-${pkgver}
+ python setup.py install --root=$pkgdir
+}